0
Not a bug

HTTPS connectivty monitoring is not working

InteractMarketing 7 years ago updated by Konstantin (Here to help) 7 years ago 9

I'm trying to add monitoring for https://www.fbcontestapp.com but there is not option for HTTPS so I have added it as HTTP with port 443, but it looks like is not working as should (to connect as secure connection to that web site).

1. Enter into Component view

2. Click New Monitor

3. Select Web-server Monitors

4. Select HTTP/HTTPs

5. On the next screen select Security (SSL/TLS) on the right.

6. On the next screen put port number 443 (although it should be cosen by defaut)

Please let me know which wizard you used: New Component wizard or New Monitor wizard - so that we fix the usability accordingly.

Thanks

Well, I have see there only Add New Component. I don't have New Monitor add button.

Strange - I was able to get there using Chrome. On FireFox somehow I'm only able to add New Components.

In this case if you put a https URL (https://www.fbcontestapp.com) to the New Component wizard it will be smart enough to start monitoring on 443 port :)

It wasn't working with port 443 based what I have mentioned in the original post.

Well, it just worked for me.

Could you please describe the sequence of steps you did and send me a screenshot of what's not working. There should be some info in error details as well.

Thanks.

1) Add New Component

2) Web-Server

3) URL: www.fbcontestapp.com and protocol HTTP

4) Go to Advanced Options

5) Monitor Settings -> Port Number: 443, Path: /

6) Each Monitoring Agent become marked on red

Got it. 

You can not switch to SSL by just changing the port. So what you have is plain HTTP requests going to port waiting for SSL handshake. 


The correct steps are:


1) Add New Component

2) Web-Server

3) URL: https://www.fbcontestapp.com and protocol HTTP (which inludes HTTPS, we will fix GUI to put a note)

That's it.