0
Under review

Agent won't connect on Debian Linux server

Zbyszek Matuszewski 4 years ago updated by Ilya (Here to help) 4 years ago 2

After fresh install agen't cannot connect. Got this (tried twice with same result):


root@server:~# curl -k -s https://anturis.com/api/1/agent/install/webvizar/84f16fd5082743f4_nop | sh

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 20.8M 100 20.8M 0 0 4491k 0 0:00:04 0:00:04 --:--:-- 4999k

Installing...

creating /opt/anturis...
creating /opt/anturis/bin...
creating /opt/anturis/etc...
creating /opt/anturis/lib...
creating /opt/anturis/log...
creating /opt/anturis/data...
creating /opt/anturis/lib/imageformats...
Starting Anturis Agent
Setting settings...
Can't connect to agent
Setting settings...
Can't connect to agent
Connecting to server...
Can't connect to agent


Log fragments:


2016.04.14 17:06:42 0.437 LOGGING: Info: ****************************************************

2016.04.14 17:06:42 0.437 LOGGING: Info: ****************** Logger Started ******************
2016.04.14 17:06:42 0.437 LOGGING: Info: ****************************************************
2016.04.14 17:06:42 0.437 LOGGING: Info: logfile log level = Info
2016.04.14 17:06:42 0.437 LOGGING: Info: console log level = Error
2016.04.14 17:06:42 0.862 SERVICE: Info: System event: Information: Anturis Monitoring Agent started
2016.04.14 17:06:43 1.638 PLUGINMGR: Info: Initializing plugin manager
2016.04.14 17:06:43 1.638 PLUGINMGR: Info: 11 native plugin(s) found:

...

2016.04.14 17:06:53 11.767 SERVCON: Info: agent_name=server
2016.04.14 17:06:53 11.767 SERVCON: Info: user_name=webvizar
2016.04.14 17:06:53 11.767 SERVCON: Info: provider=QNAM

...

2016.04.14 17:06:53 11.767 SERVCON: Info: fail_pause_waittask_max=10000

2016.04.14 17:06:53 11.774 MSGBUS: Info: bus device with id 112 registered

2016.04.14 17:06:53 12.073 SERVREQ: Info: Expected server certificate: QSslCertificate( "3" , "eb:53:07:d6:30:f9:27:c5" , "Ytuef6wSpywDGnTSQ5t5fw==" , "Internet Widgits Pty Ltd" , "Internet Widgits Pty Ltd" , QMap() , QDateTime("Ĺ
) )
2016.04.14 17:06:54 12.348 CTLCNTR: Info: Initializing control connector
2016.04.14 17:06:54 12.348 LOCALCON: Info: listening at 44771
2016.04.14 17:06:54 12.897 SERVREQ: Info: Redirection attempt 1 -> https://anturis.com/api/1/agent/authenticate

2016.04.14 17:06:54 13.026 SERVREQ: Error: Request POST to https://anturis.com/api/1/agent/authenticate failed (ServerAuthenticationError: AuthenticationRequiredError("Host requires authentication"): 401("Unauthorized")) with QVariant(QVariantMap, QMap(("error", QVariant(QString, "StatusUnauthorized") ) ) )

Under review

'Can't connect to agent' - Looks like anturis service just service started slowly.

What debian version do you use?