0
Answered

Threshold check failed

noddingpanda 6 years ago updated by Ilya (Here to help) 6 years ago 12
I have newly installed Anturis as a Plesk additional service. Both my smtp-process and web-process have come up as "Theshold check failed. Value should be greater than 1, expression is 0". I have no idea what this means or how to solve it.
I have also tried to start uptime monitor on the Plesk Addon but it is unable to create it.
Would appreciate your help.
Under review
Hi,

About SMTP issue. Default mail server for plesk is Courier. You are using qmail server. So, need to change settings for smtp monitor. This monitor will check qmail process which responsible for sending messages.
Login to your account at anturis.com. Open smtp monitor and change filter to:
process name to qmail-send 
command line set *
And then press Save button.
See screenshot, how settings should be:

About web process monitor. Need to change settings. Different version of apache has differents process name. We will fix this issue in the next plugin version. Now you can fix it by yourself:
Login to your account at anturis.com. Open web process monitor and change filter to:
process name to httpd;apache;apache2
command line set *
And then press Save button.

See screenshot, how settings should be:

About uptime monitor. Please clear chache in your web browser and try to start Uptime monitor again.
Sorry for the inconvenience. 
Thanks for your help, the first two post worked perfectly. However, the uptime monitor still does not work after clearing the cache from my browser, Any other ideas?
get_logs.tar.gz

Please download attached archive to your server, extract it and run command ./collect_info.sh >out.log
After that send us out.log to support@anturis.com

Hi,

Thanks for log.  Unfortunately, logs doesn't how any problem. 

Can you please try to setup uptime monitor again but with one complication:
1. Before you pressed on Uptime button, open Developer Tools in Chrome(press F12, or from Chrome menu->Tools->Developer tools)
2. In Developer tools click on Network tab
3. Press on 'Record Network Log' in case is gray. 'Record Network Log' is a gray/red circle in the top-left corner (it is the red on screenshot).
4. Press on 'Clear' to the right of 'Record Network Log'
5. Go back to Chrome and click on Uptime monitor creation
6. When error appears go back to Developer console and find request like on screenshot: install.php, modules/anturis/uptime-monitoring/install.php
7. Report us what you see in Response tab for this request.
Hi

For install.php, I get:

Uptime :: Plesk installer error: Error during Plesk API RPC request 1013: There is no such a service plan

If it helps, every time I request to start the monitor a new customer is created with the login of anturis-monitoring. I presume its looking for a service plan name, which I could manually create?
Yes, please create service plan Unlimited. You can set any limits. We need a little space on disk( less than 10 mb) and database.
Excellent, that's all sorted now. Thank you.
Great! We'll add service plan creating in new version of our plugins to prevent such cases. 
Sorry for the inconvenience.